Live status
History

SEPA Instant Partial Outage

Incident Report for Stripe

Update

Instant payouts to bank accounts and Bank Transfers payments in Europe continue to experience delays due to broader issues affecting SEPA Instant. This issue is also resulting in elevated errors on Pay by Bank payments beginning at 08:40 UTC. All other payouts, including instant payouts to debit cards, remain unaffected. We are continuing to engage with our upstream partners, and will provide further updates as soon as they are available.
Posted May 19, 2026 - 21:15 UTC

Identified

Instant payouts in EUR to bank accounts and Bank Transfers payments continue to experience delays due broader industry issues affecting SEPA Instant. All other payouts, including instant payouts to debit cards, remain unaffected. We will provide further updates as soon as possible.
Posted May 19, 2026 - 15:14 UTC

Investigating

Instant payouts in EUR to bank accounts and Bank Transfers payments are experiencing delays and some might fail due to a broader industry issue affecting SEPA Instant. All other payouts, including instant payouts to debit cards, are unaffected. We're investigating and will provide an update once resolved.
Posted May 19, 2026 - 11:58 UTC
This incident affects: Acquirers and payment methods.