Live status
History

Elevated Blik errors

Incident Report for Stripe

Resolved

From 20:40–21:15 UTC, we saw elevated errors on Blik payments. This is now resolved.
Posted Nov 04, 2025 - 23:49 UTC

Investigating

We're currently investigating elevated errors on Blik payments. We'll post an update soon.
Posted Nov 04, 2025 - 21:34 UTC
This incident affected: Acquirers and payment methods.