Live status
History

Elevated Swish errors

Incident Report for Stripe

Resolved

From 15:10–19:28 UTC, Swish experienced a service disruption impacting a number of service providers. This is now resolved.
Posted May 06, 2025 - 20:43 UTC

Investigating

As of 15:10 UTC, we've seen elevated errors on Swish payments. We're continuing to investigate and will post further updates.
Posted May 06, 2025 - 15:47 UTC
This incident affected: Acquirers and payment methods.