Live status
History
Dashboard loading errors for some users
Incident Report for Stripe
Resolved
From 08:23–10:40 UTC, we saw some users are getting an error message when trying to load the Dashboard. This is now resolved.
Posted Apr 03, 2024 - 10:40 UTC
Identified
As of 08:23 UTC, we are seeing some users are getting an error message when trying to load the Dashboard. We have identified the cause, and are working on a fix.
Posted Apr 03, 2024 - 10:20 UTC
This incident affected: Stripe core components.