Get incident updates and maintenance status messages in Slack. Permission to install a new app on your Slack workspace is required. Once integrated, you must invite '@Statuspage' to the Slack channel in which you wish to receive notifications.
For more subscription information, visit our instructions in Support.
As of May 05, 2025, 16:45 UTC, we have successfully resolved the issue that was preventing real-time data from loading within the Billing Analytics dashboards. All dashboard charts are now recovered.
Posted May 06, 2025 - 17:04 UTC
Identified
We have identified the underlying issue preventing real-time data from loading within the Billing Analytics dashboards. Engineers remain actively engaged and are working to restore real-time data as quickly as possible.
Posted May 05, 2025 - 19:27 UTC
Update
All dashboard charts have recovered historic data. We continue to investigate the underlying issue preventing real-time data from loading within the Billing Analytics dashboards.
Posted May 05, 2025 - 17:14 UTC
Update
We’re currently seeing recovery with most dashboard data, though Billing Analytics data is still not consistently loading. We are continuing to investigate.
Posted May 05, 2025 - 16:01 UTC
Investigating
We’re currently investigating issues loading some Dashboard charts. We’ll post an update soon.