Live status
History

Elevated Dashboard, Express Dashboard and Mobile surfaces errors

Incident Report for Stripe

Resolved

From 07:55 - 09:59 UTC, we experienced issues with Dashboard, Express Dashboard on all platforms and Mobile surfaces. This is now resolved. API requests and payment processing were unaffected by this issue .
Posted Mar 30, 2026 - 10:04 UTC

Investigating

As of 07:55 UTC, we are experiencing issues with the Dashboard, Express Dashboard on all platforms and Mobile surfaces. We’re continuing to investigate and will post further updates. API requests and payment processing are unaffected by this issue.
Posted Mar 30, 2026 - 08:52 UTC
This incident affected: Stripe core components.