Live status
History

Elevated Klarna errors

Incident Report for Stripe

Resolved

From 06:03 to 06:26 UTC, we saw elevated error rates and response times for payments using Klarna. This issue is now resolved.
Posted Sep 25, 2026 - 07:42 UTC

Investigating

We're currently investigating elevated error rates and response times with payments. We'll post an update soon.
Posted Sep 25, 2026 - 06:23 UTC
This incident affected: Global payments and Acquirers and payment methods.