Get incident updates and maintenance status messages in Slack. Permission to install a new app on your Slack workspace is required. Once integrated, you must invite '@Statuspage' to the Slack channel in which you wish to receive notifications.
For more subscription information, visit our instructions in Support.
Between 16:45 and 18:00 UTC, Swish experienced a service disruption that impacted the Swish payment method. The issue was external to Stripe and is now resolved.
Posted Jun 05, 2025 - 18:24 UTC
Identified
We have confirmed a service disruption of the Swish payment method that began at 16:45 UTC. This issue is external to Stripe and is causing increased error rates for transactions processed through the Swish payment method. We are actively monitoring the situation and will provide updates as more information becomes available.
Posted Jun 05, 2025 - 17:49 UTC
Investigating
As of 17:03 UTC, we've seen elevated errors on Swish payments. We're continuing to investigate and will post further updates.
Posted Jun 05, 2025 - 17:06 UTC
This incident affected: Acquirers and payment methods.