Get incident updates and maintenance status messages in Slack. Permission to install a new app on your Slack workspace is required. Once integrated, you must invite '@Statuspage' to the Slack channel in which you wish to receive notifications.
For more subscription information, visit our instructions in Support.
From 01:35 - 05:20 UTC, we saw elevated errors with SMS delivery in the US. This is now resolved.
Posted Apr 18, 2026 - 06:42 UTC
Identified
Since 01:35 UTC, we’ve been experiencing US SMS delivery issues affecting 2FA and OTP codes for Dashboard, Link, Issuing, and Express users. Non-SMS 2FA methods (security keys, authenticator apps) still work. We’re actively monitoring and will update when resolved.
Posted Apr 18, 2026 - 04:40 UTC
Investigating
We're currently experiencing SMS delivery issues in the US, affecting 2-Factor authentication for dashboard users as well as the OTP code for Link and Express users. We'll post an update as soon as we have it.