Live status
History

Elevated errors on Klarna payments

Incident Report for Stripe

Resolved

Between 10:45 - 13:39 UTC there was a disruption with the Klarna payment method causing increased error rates for Klarna transactions. The issue is now resolved.
Posted Mar 19, 2026 - 14:18 UTC

Update

We are continuing to investigate this issue.
Posted Mar 19, 2026 - 12:19 UTC

Investigating

We are currently observing elevated errors on Klarna payments.
Payments are likely affected due to degraded performance reported by Klarna.
We will continue to monitor the issue and an update will be provided as soon as more information becomes available.
Posted Mar 19, 2026 - 12:18 UTC
This incident affected: Acquirers and payment methods.