Live status
History

Elevated Interac errors

Incident Report for Stripe

Resolved

There was an issue causing elevated error rates and response times with card payments through Interac. The issue is now resolved.
Posted Sep 10, 2026 - 21:28 UTC

Investigating

We're currently investigating elevated error rates and response times with payments through Interac. We'll post an update soon.
Posted Sep 10, 2026 - 20:53 UTC
This incident affected: Global payments and Acquirers and payment methods.