Get incident updates and maintenance status messages in Slack. Permission to install a new app on your Slack workspace is required. Once integrated, you must invite '@Statuspage' to the Slack channel in which you wish to receive notifications.
For more subscription information, visit our instructions in Support.
From 6:45 UTC to 9:41 UTC, Affirm, Klarna, and Amazon Pay had brief periods of unavailability due to a widespread outage external to Stripe. As a result, users experienced elevated '500' errors when using these payment methods. These issues appear to be resolved, and the impacted payment methods are now enabled on all surfaces.
Posted Oct 20, 2025 - 09:52 UTC
Identified
At 6:45 UTC, we observed elevated API errors likely related to a widespread internet outage affecting Affirm, Klarna, and Amazon Pay. This outage is also causing delays in responding to support requests via phone and chat. We recommend submitting a support ticket via email.
As a result, Affirm, Klarna, and Amazon Pay have been temporarily disabled in our Checkout and Elements surfaces. API users leveraging these payment methods may still experience errors. The cause of this issue is external to Stripe.
Posted Oct 20, 2025 - 09:17 UTC
Investigating
We experiencing elevated API errors that appear related to a widespread internet outage.