Live status
History

Errors downloading files

Incident Report for Stripe

Resolved

Between 19:22 to 20:49 UTC on March 10th, file downloads were returning 404 errors. The issue is now resolved.
Posted Mar 10, 2026 - 20:53 UTC

Investigating

We’re currently investigating an issue causing file downloads to fail with 404 errors. We’ve identified the cause, and are working on a fix. We’ll post an update soon.
Posted Mar 10, 2026 - 20:43 UTC
This incident affected: Stripe core components.