Live status
History
Request-a-call support unavailable
Incident Report for Stripe
Resolved
From 15:01–18:05 UTC, we experienced issues responding to support requests via phone call. This is now resolved.
Posted Apr 22, 2024 - 19:15 UTC
Investigating
We’re currently experiencing issues responding to support requests via phone call. Please use Chat or reference our self-help documentation[0] until the issue is resolved. We are working with our provider and will post an update soon.

[0] https://docs.stripe.com/
Posted Apr 22, 2024 - 15:55 UTC
This incident affected: Stripe core components.