Live status
History

Elevated Affirm errors

Incident Report for Stripe

Resolved

Between 18:24 - 19:43 UTC there were elevated errors on Affirm payments. The issue is now resolved.
Posted Jun 12, 2025 - 20:29 UTC

Investigating

As of 18:24 UTC, we've seen elevated errors on Affirm payments. We're continuing to investigate and will post further updates.
Posted Jun 12, 2025 - 18:26 UTC
This incident affected: Acquirers and payment methods.