Live status
History

Elevated Swish errors

Incident Report for Stripe

Resolved

Between 04:00 and 06:17 UTC, Swish experienced a service disruption due to a disturbance with Swedbank. The issue has been resolved.
Posted Jun 10, 2025 - 07:08 UTC

Investigating

We're seeing elevated errors on Swish payments as of 04:00 UTC due to an issue with Swedbank. We will provide updates as necessary.
Posted Jun 10, 2025 - 05:35 UTC
This incident affected: Acquirers and payment methods.