Live status
History

Elevated card declines for some users in Mexico

Incident Report for Stripe

Resolved

From 04:16 - 05:00 UTC, some card transactions in Mexico experienced elevated declines due to an issuing bank being temporarily unavailable. This is now resolved.
Posted Jun 11, 2026 - 05:16 UTC

Investigating

As of 04:16 UTC, some card transactions in Mexico are experiencing elevated declines due to an issuing bank being temporarily unavailable. We're in touch with the card network and will post an update as soon as they become available.
Posted Jun 11, 2026 - 05:05 UTC
This incident affected: Acquirers and payment methods.