Get incident updates and maintenance status messages in Slack. Permission to install a new app on your Slack workspace is required. Once integrated, you must invite '@Statuspage' to the Slack channel in which you wish to receive notifications.
For more subscription information, visit our instructions in Support.
Between 20:15 September 16th and 00:08 September 17th UTC, we saw elevated card authorization errors related to an issuing bank in United States which impacted some Visa transactions. This is now resolved.
Posted Sep 17, 2026 - 01:17 UTC
Monitoring
We’re currently seeing elevated card authorization errors related to an issuing bank in North America, which is impacting some Visa transactions. We've seen some recovery and are continuing to monitor.
Posted Sep 17, 2026 - 00:10 UTC
Investigating
We're currently investigating elevated error rates and response times with Visa payments. We'll post an update soon.
Posted Sep 16, 2026 - 23:33 UTC
This incident affected: Acquirers and payment methods.