Live status
History

Elevated card declines for some users in Mexico

Incident Report for Stripe

Resolved

Between 04:16 – 07:06 UTC, we saw elevated declines with some card transactions in Mexico due to an issuing bank being temporarily unavailable. This is now resolved.
Posted Jun 10, 2026 - 07:41 UTC

Investigating

As of 04:16 UTC, some card transactions in Mexico are experiencing elevated declines due to an issuing bank being temporarily unavailable. We're closely monitoring the issue and will post an update once we have observed recovery.
Posted Jun 10, 2026 - 05:17 UTC
This incident affected: Acquirers and payment methods.