Live status
History

Elevated Swish errors

Incident Report for Stripe

Resolved

From 19:44–20:11 UTC, Swish experienced a service disruption impacting a number of service providers. This is now resolved.
Posted May 07, 2025 - 20:33 UTC

Investigating

We’re currently investigating a service disruption with Swish starting at 19:44 UTC. We're monitoring for updates and will provide an update as soon as possible.
Posted May 07, 2025 - 20:24 UTC
This incident affected: Acquirers and payment methods.