Live status
History

Elevated Apple Pay errors

Incident Report for Stripe

Resolved

From 15:13-17:04 UTC, Apple Pay experienced a service disruption impacting a number of service providers. The issue was external to Stripe and is now resolved.
Posted May 16, 2025 - 18:07 UTC

Investigating

As of 15:13 UTC, we've seen elevated errors for Apple Pay payments. We're continuing to monitor the issue and will post further updates.
Posted May 16, 2025 - 16:11 UTC
This incident affected: Acquirers and payment methods.