Live status
History

Elevated errors on Interac payments

Incident Report for Stripe

Resolved

From 04:29-10:51 UTC, we saw elevated error rates and response times with card payments processed via Interac. This is now resolved.
Posted Aug 10, 2025 - 11:19 UTC

Identified

We received confirmation from Interac that the issue is due to a planned maintenance and it is expected to be concluded by 12:00 UTC August 10th. We are in touch with the team and will provide an update as soon as it becomes available.
Posted Aug 10, 2025 - 06:55 UTC

Investigating

We have identified an issue outside of our platform resulting in elevated failing transactions processed through Interac starting at 04:29 UTC.
We have contacted Interac and we will provide an update as soon as it becomes available.
Posted Aug 10, 2025 - 05:24 UTC
This incident affected: Acquirers and payment methods.