Live status
History

Increase in Multibanco Processing Errors

Incident Report for Stripe

Resolved

From 05:05–16:06 UTC, we saw elevated errors on Multibanco payments. This is now resolved.
Posted Jun 02, 2025 - 16:45 UTC

Update

As of 05:05 UTC, one of Stripe’s upstream processing partners is experiencing a partial outage, resulting in elevated errors on Multibanco payments. This is likely impacting a number of payment processors.
Posted Jun 02, 2025 - 11:22 UTC

Identified

As of 05:05 UTC, we’ve seen elevated errors on Multibanco payments. This is likely impacting a number of payment processors.
Posted Jun 02, 2025 - 10:46 UTC
This incident affected: Acquirers and payment methods.