Live status
History

Connected account edit page errors

Incident Report for Stripe

Resolved

From 10:41 - 12:02 UTC, we saw elevated errors on attempts to edit information related connected accounts via the dashboard. This is now resolved.
Posted Nov 30, 2023 - 12:08 UTC

Investigating

As of 10:41 UTC, we’ve seen elevated errors on attempts to edit information related connected accounts via the dashboard. We’re continuing to investigate and will post further updates
Posted Nov 30, 2023 - 11:28 UTC
This incident affected: Stripe core components.