Live status
History

Elevated Authentication Requests

Incident Report for Stripe

Resolved

Between 11:40 UTC and 14:35 UTC we observed elevated Authentication Requests for card transactions in SCA scope. This issue has now been resolved.
Posted May 08, 2026 - 14:47 UTC

Investigating

We are currently observing elevated Authentication Requests related to issuing banks in the UK and France which is impacting some card transactions.
Posted May 08, 2026 - 14:07 UTC
This incident affected: Acquirers and payment methods.