Live status
History

Elevated declines on Mastercard

Incident Report for Stripe

Resolved

Between 04:01 and 05:42 UTC, we saw elevated error rates and response times with Mastercard payments. This is now resolved. Our engineering teams will continue to monitor.
Posted Aug 15, 2026 - 06:21 UTC

Monitoring

As of 05:42 UTC, elevated error rates and response times with Mastercard payments have began to recover. Stripe teams will continue to monitor until fully resolved.
Posted Aug 15, 2026 - 06:04 UTC

Identified

We're currently seeing elevated error rates and response times with Mastercard payments. We have confirmed the outage is external to the Stripe infrastructure.
Posted Aug 15, 2026 - 05:25 UTC

Investigating

We're currently investigating elevated error rates and response times with Mastercard payments. We'll post an update soon.
Posted Aug 15, 2026 - 04:49 UTC
This incident affected: Acquirers and payment methods.