Live status
History

Elevated BLIK errors

Incident Report for Stripe

Resolved

From 19:40 to 22:10 UTC, we saw elevated errors for Blik payment method payments. This is now resolved.
Posted Jul 20, 2026 - 22:32 UTC

Identified

We're currently seeing a degradation of the Blik payment method. Our partner has identified the cause and is working on a fix.
Posted Jul 20, 2026 - 22:09 UTC

Investigating

We're currently investigating elevated error rates and response times with payments. We'll post an update soon.
Posted Jul 20, 2026 - 21:42 UTC
This incident affected: Global payments and Acquirers and payment methods.