Live status
History

Power grid issues in Europe

Incident Report for Stripe

Resolved

As of April 29, 2025, the external issue affecting power grids responsible for delivering electricity in some European countries, particularly in Spain and Portugal has been mostly restored. Stripe services were not impacted by these events. Our teams will continue to monitor the situation and update you again if required.
Posted Apr 29, 2025 - 13:07 UTC

Monitoring

We are aware of an external issue affecting power grids responsible for delivering electricity in several European countries, particularly in Spain and Portugal. Stripe services have not been impacted by these events and remain fully operational. We are closely monitoring the situation with our engineering and support teams.
Posted Apr 28, 2025 - 15:45 UTC
This incident affected: Acquirers and payment methods.