Live status
History

Elevated Swish errors

Incident Report for Stripe

Resolved

From 18:15-19:08 UTC, Swish experienced a service disruption impacting a number of service providers. The issue was external to Stripe and is now resolved.
Posted May 15, 2025 - 19:14 UTC

Investigating

As of 18:59 UTC, we've seen elevated errors on Swish payments. We're continuing to investigate and will post further updates.
Posted May 15, 2025 - 19:01 UTC
This incident affected: Acquirers and payment methods.