Live status
History

Elevated latency for Visa EU transactions

Incident Report for Stripe

Resolved

From 17:49 – 19:45 UTC, we saw elevated error rates and response times with Visa EU payments due to an issue experienced by an upstream partner. This is now resolved.
Posted Feb 12, 2026 - 19:53 UTC

Investigating

We’re currently investigating elevated error rates and response times with Visa EU payments. We’ll post an update soon.
Posted Feb 12, 2026 - 18:38 UTC
This incident affected: Global payments.