Live status
History

Elevated iDeal errors

Incident Report for Stripe

Resolved

From 13:05–19:15 UTC, we saw elevated errors on iDeal payments. This is now resolved.
Posted Sep 22, 2025 - 20:14 UTC

Investigating

We're currently investigating elevated errors on iDeal payments. We'll post an update soon.
Posted Sep 22, 2025 - 16:30 UTC
This incident affected: Acquirers and payment methods.