Live status
History

500 errors across multiple APIs and interfaces

Incident Report for Stripe

Resolved

From 08:06 to 10:59 UTC, we saw a decline in success rates that resulted in 500 errors affecting dashboard availability across multiple services. Users were experiencing issues when accessing the dashboard interfaces. This has now been resolved.
Please note that there were no API issues; the problems were specific to the dashboard.
Posted Sep 19, 2025 - 11:15 UTC

Investigating

We're currently investigating the decline in success rates resulting in 500 errors across multiple services and dashboards. Users are experiencing issues while accessing various interfaces. We're continuing to investigate and will post further updates at regular intervals.
Posted Sep 19, 2025 - 09:06 UTC
This incident affected: Stripe API and Stripe core components.