Live status
History

Google Pay authorization issues

Incident Report for Stripe

Resolved

The issues with Google Pay have been resolved and payment options have been enabled. We're continuing to monitor the issue.
Posted Apr 11, 2025 - 17:15 UTC

Update

We continue to see issues with Google Pay authorizations. We've temporarily disabled GooglePay as a payment option while we collaborate with Google on a solution. We’re continuing to monitor the issue and will post further updates soon.
Posted Apr 11, 2025 - 16:39 UTC

Monitoring

As of April 11, 2025, 14:51 UTC, we’ve seen a significant drop in Google Pay authorizations. We’re continuing to monitor the issue and will post further updates soon.
Posted Apr 11, 2025 - 15:56 UTC
This incident affected: Acquirers and payment methods.