Live status
History

Elevated Apple Pay errors

Incident Report for Stripe

Resolved

Between 02:59–04:58 UTC May 16th, we saw elevated error rates and response times with Apple Pay requests. This is now resolved.
Posted May 16, 2026 - 05:21 UTC

Investigating

We're currently investigating elevated Apple Pay errors. We'll post an update soon.
Posted May 16, 2026 - 03:38 UTC
This incident affected: Acquirers and payment methods.