Live status
History

Unexpected reauthentication requests

Incident Report for Stripe

Resolved

Between 17:29–18:45 UTC June 18th, some users experienced intermittent login issues. This is now resolved.
Posted Jun 18, 2025 - 19:14 UTC

Investigating

We’re currently investigating an issue which is resulting in some users experiencing an unexpected prompt to re-enter their password or login again with SSO. We’ll post an update soon.
Posted Jun 18, 2025 - 18:25 UTC
This incident affected: Stripe core components.