Live status
History

Elevated Swish errors

Incident Report for Stripe

Resolved

From 18:53 UTC to 19:18 UTC on 2026-08-29, we saw elevated errors on Swish payments due to a service degradation on the Swish side. This is now resolved. We will continue to monitor for any further issues and will provide updates if needed.
Posted Aug 29, 2026 - 20:44 UTC

Investigating

We're currently investigating elevated error rates and response times with payments. We'll post an update soon.
Posted Aug 29, 2026 - 19:28 UTC
This incident affected: Global payments and Acquirers and payment methods.