Live status
History

Elevated Interac errors

Incident Report for Stripe

Resolved

The maintenance at Interac has concluded successfully. We’ve observed reduced error rates and improved response times with Interac payments in Canada. The issue is now resolved.
Posted Sep 13, 2026 - 15:49 UTC

Monitoring

We have observed recovery since 04:50 UTC but have been advised by Interac that ongoing maintenance will occur until 15:00 UTC. During this period, there may be intermittent errors and increased response times with Interac payments. We are monitoring closely and will share updates as soon as they are available.
Posted Sep 13, 2026 - 05:17 UTC

Investigating

Since 03:46 UTC, we’ve observed elevated error rates and increased response times with Interac payments, affecting in-person transactions in Canada. We have reached out to Interac and will share updates as soon as they are available.
Posted Sep 13, 2026 - 04:45 UTC
This incident affected: Acquirers and payment methods.