Live status
History

Dashboard authentication errors

Incident Report for Stripe

Resolved

From 10:04 - 13:38 UTC, we experienced issues with elevated authentication errors affecting some Dashboard features. This is now resolved.
Posted May 07, 2026 - 13:53 UTC

Investigating

We're currently investigating elevated authentication errors affecting some Dashboard features. We'll post an update soon.
Posted May 07, 2026 - 13:07 UTC
This incident affected: Stripe core components.