Get incident updates and maintenance status messages in Slack. Permission to install a new app on your Slack workspace is required. Once integrated, you must invite '@Statuspage' to the Slack channel in which you wish to receive notifications.
For more subscription information, visit our instructions in Support.
Between 07:23 UTC on June 4th and 13:51 UTC on June 5th, we saw elevated error rates and response times with some Cartes Bancaires payments. This is now resolved.
Posted Jun 05, 2026 - 14:41 UTC
Update
We are continuing to see elevated error rates and response times with some Cartes Bancaires payments due to an issuer-side degradation starting 07:23 UTC June 4th. We are actively monitoring and will provide a further update as more information becomes available.
Posted Jun 05, 2026 - 12:22 UTC
Identified
We’re currently seeing elevated error rates and response times with some Cartes Bancaires payments due to an issuer-side degradation starting 07:23 UTC June 4th. We believe this outage is outside of Stripe's infrastructure. This is likely impacting a number of payment processors. We’re continuing to monitor and will post further updates.
Posted Jun 05, 2026 - 05:33 UTC
This incident affected: Acquirers and payment methods.