Live status
History

Dashboard loading errors

Incident Report for Stripe

Resolved

From 00:21–01:48 UTC, certain dashboard pages were failing to load properly. This has now been resolved.
Posted Mar 12, 2025 - 03:33 UTC

Monitoring

As of 01:48 UTC, the dashboard pages have recovered. We’re continuing to validate that this issue is fully resolved and we’re working to prevent recurrence.
Posted Mar 12, 2025 - 02:28 UTC

Identified

We're currently seeing recovery as of 01:48 UTC. We've identified the cause, and are working on a fix.
Posted Mar 12, 2025 - 01:56 UTC

Investigating

Certain dashboard pages are failing to load properly and may be unresponsive. We’re continuing to investigate and we’ll post an update soon.
Posted Mar 12, 2025 - 01:20 UTC
This incident affected: Stripe core components.