Live status
History

Elevated Discover errors

Incident Report for Stripe

Resolved

Between 08:06 and 09:03 UTC, we observed a service disruption that impacted the Discover payment method. The issue was external to Stripe and is now resolved.
Posted Jul 14, 2025 - 09:21 UTC

Investigating

We're currently investigating a service disruption of the Discover payment method that began at 08:06 UTC. This issue is external to Stripe and is causing increased error rates for transactions processed through the Discover payment method. We are actively monitoring the situation and will provide updates as more information becomes available.
Posted Jul 14, 2025 - 09:15 UTC
This incident affected: Acquirers and payment methods.