Live status
History

Elevated errors for Multiple Payment Methods

Incident Report for Stripe

Resolved

From 11:35 UTC to 12:08 UTC Paypal, Alma, FPX and Payto had brief periods of unavailability due to a widespread outage external to Stripe which is now resolved.
Posted Nov 18, 2025 - 14:53 UTC

Monitoring

From 11:35 UTC to 12:08 UTC Paypal, Alma, FPX and Payto had brief periods of unavailability due to a widespread outage external to Stripe. As a result, users experienced elevated errors when using these payment methods. These issues appear to be resolved. We’re continuing to validate that this issue is fully resolved.
Posted Nov 18, 2025 - 13:38 UTC

Investigating

As of 11:35 UTC, we've seen elevated errors on PayPal, Alma, FPX and Payto payments. We're continuing to investigate and will post further updates.
Posted Nov 18, 2025 - 12:03 UTC
This incident affected: Acquirers and payment methods.