Get incident updates and maintenance status messages in Slack. Permission to install a new app on your Slack workspace is required. Once integrated, you must invite '@Statuspage' to the Slack channel in which you wish to receive notifications.
For more subscription information, visit our instructions in Support.
From 10:12 to 12:07 UTC, the Multibanco payment method experienced a service disruption affecting transaction processing. The issue was external to Stripe and has now been resolved.
Posted May 14, 2025 - 11:29 UTC
Investigating
We're currently investigating a full service disruption of the Multibanco payment method that began at 10:12 UTC. This issue is external to Stripe and is causing increased error rates for transactions processed through the Multibanco payment method. We are actively monitoring the situation and will provide updates as more information becomes available.
Posted May 14, 2025 - 09:34 UTC
This incident affected: Acquirers and payment methods.