Live status
History

Elevated declines on Mastercard

Incident Report for Stripe

Resolved

We have confirmed that as of 09:42 UTC, Mastercard has resolved the underlying issue. At this time, we are no longer seeing errors or elevated response times.

We will continue to monitor and provide another update if required.
Posted Mar 09, 2025 - 11:10 UTC

Monitoring

We have not observed declines on the Mastercard network since 09:05 UTC and are currently monitoring the issue until Mastercard confirms full resolution.
Posted Mar 09, 2025 - 10:01 UTC

Investigating

We’re currently investigating ongoing error and elevated response times with Mastercard payments which started at 07:20 UTC. We are working with the Mastercard team and will post an update as soon as possible.
Posted Mar 09, 2025 - 08:11 UTC
This incident affected: Acquirers and payment methods.