Live status
History

Support site not loading

Incident Report for Stripe

Resolved

There was an issue between 22:58 to 23:29 UTC, wherein support.stripe.com was not loading and users were seeing 'service not found' on the page. The issue is now resolved.
Posted Jan 26, 2026 - 23:32 UTC

Investigating

We're currently investigating an issue starting at 22:58 UTC, wherein support.stripe.com is not loading and users are seeing 'service not found' on the page. You can still contact Stripe support by using the Stripe Dashboard help icon. We'll post an update as soon as the issue is resolved.
Posted Jan 26, 2026 - 23:25 UTC
This incident affected: Stripe core components.