Live status
History

Stripe Support Systems issue

Incident Report for Stripe

Resolved

The partner issue affecting our support systems has been resolved. Stripe's live support channels have been restored and are operating normally. This issue has been resolved.
Posted Sep 20, 2026 - 08:10 UTC

Investigating

We're currently investigating issues with our support systems due to an upstream partner issue, starting 07:10 UTC. We've currently disabled live support channels and are monitoring the affected service provider. We will provide further updates once we have observed recovery.
Posted Sep 20, 2026 - 07:31 UTC
This incident affected: Stripe core components.