Get incident updates and maintenance status messages in Slack. Permission to install a new app on your Slack workspace is required. Once integrated, you must invite '@Statuspage' to the Slack channel in which you wish to receive notifications.
For more subscription information, visit our instructions in Support.
Between 09:07 UTC and 11:54 UTC we observed elevated failures for 3DS transactions on Commonwealth Bank of Australia issued cards. This issue was external to Stripe and is now resolved.
Posted Jan 29, 2026 - 12:32 UTC
Investigating
We are currently investigating elevated failures for 3DS transactions on Commonwealth Bank of Australia issued cards starting at 09:07 UTC. This issue is external to Stripe and we are actively monitoring the situation. We will provide updates as more information becomes available.
Posted Jan 29, 2026 - 10:18 UTC
This incident affected: Acquirers and payment methods.