Live status
History

Elevated EPS errors

Incident Report for Stripe

Resolved

From 14:37 to 15:15 UTC, the EPS payment method experienced a service disruption affecting transaction processing. The issue was external to Stripe and has now been resolved.
Posted May 12, 2025 - 15:50 UTC

Investigating

We're currently investigating a full service disruption of the EPS payment method that began at 14:37 UTC. This issue is external to Stripe and is causing increased error rates for transactions processed through the EPS payment method. We are actively monitoring the situation and will provide updates as more information becomes available.
Posted May 12, 2025 - 15:31 UTC
This incident affected: Acquirers and payment methods.