Live status
History

Elevated declines on Discover and Diners Club

Incident Report for Stripe

Resolved

Between 04:50 and 07:44 UTC, we saw elevated error rates with Discover and Diners Club payments. The issue was external to Stripe and is now resolved.
Posted Sep 26, 2025 - 08:53 UTC

Investigating

As of 04:50 UTC, we’ve seen elevated error rates with Discover and Diners Club payments. This issue is external to Stripe.
Posted Sep 26, 2025 - 07:11 UTC
This incident affected: Acquirers and payment methods.