Live status
History

Elevated declines on Mastercard

Incident Report for Stripe

Resolved

Between 06:27 and 07:15 UTC, Mastercard experienced errors that impacted card authorization processes. The issue was external to Stripe and is now resolved.
Posted Jun 03, 2025 - 13:01 UTC

Monitoring

As of 07:15 UTC, Mastercard errors have begun to subside. We’re continuing to validate that this issue is fully resolved.
Posted Jun 03, 2025 - 08:04 UTC

Investigating

As of 06:32 UTC, we’ve seen elevated declines on Mastercard. We’re continuing to investigate and will post further updates soon.
Posted Jun 03, 2025 - 07:19 UTC
This incident affected: Acquirers and payment methods.